关于DedeCMS Error: (PHP 5.3 and above) Please set 'request_order' ini value to include C,G and P (recommended: 'CGP‘) 的解决办法 通用 错误提示

三郎 2018-3-23 541

在使用PHP5.3或者以上版本的PHP安装程序的时候,经常有人碰到“DedeCMS Error: (PHP 5.3 and above) Please set 'request_order' ini value to include C,G and P (recommended: 'CGP‘)  in php.ini”这样的提示。


有人百度,结果是修改程序里面的什么文件,然后把这个提示屏蔽掉,其实这样是不可取的。程序有这样的提示一定有它的道理。


真正的解决办法是:

一、找到你的php配置文件php.ini

二、搜索“request_order =”,记住是搜索“request_order =”。

三、修改为 request_order = "GPC"

四、重启IIS或者其他web服务器软件。

最新回复 (1)
  • 0 引用 2

    有人说“我修改了php.ini也没用啊”,这是因为你可能找错了文件。

    要找到真正要修改的那个文件,方法如下:

    复制下面的代码,保存为1.php,放在你的网站根目录:

    <?php phpinfo();?>

    然后用浏览器访问http://你的域名/1.php


    你会直接看到下面的界面:

    红框里面的就是你要修改的文件。


    记得要把1.php删掉。


    2018-3-23 回复
返回
发新帖